Tuesday, August 23, 2011

Blogger Browser Support Policy, And Ongoing Browser Development

Last month, Blogger announced their new browser support policy.
Starting next month Blogger.com will only support modern browsers.
While seemingly dismissive and rude, this change will ultimately lead to a more stable Blogger experience for all of us.

In considering the new policy, I had been recently planning to update several of my computers, which use Firefox V3.6, to V4. When I went to the Mozilla website to download a copy of Firefox V4, I found to my surprise that Mozilla is currently offering Firefox V6, with only V3.6 being offered as a second choice.

We need to remember that not only Blogger may not require us to upgrade our browsers. Both Microsoft and Mozilla, and probably the other browser companies too, are going to periodically limit our choice of supported browser version. Not all browser updates contain only shiny GUI changes - many updates are made for security and stability.

The more browsers you maintain on any computer, the more updates you'll be doing. It's all for your benefit, though.

For a canonical list of browser versions supported by Blogger, click here.

>> Top

4 comments:

Kay Dennison said...

I had to downgrade to Firefox 3.6 because 4 wouldn't work on my computer.

Emma said...

Great. i just found out today - rude and dismissive? You bet. Thanks a lot blogger.

Chuck said...

Emma,

I'm sorry that you see that as a problem. It really is to our benefit. Blogger isn't the only web application that works best, when supporting a defined range of browser versions.

Any IT product with any future has to define their environment. It's part of supporting their customer base, professionally.

Upgrade your browser - it really is a good decision.

Kay Dennison said...

Firefox 6 is a kludge. And I'll be damned if I go anywhere near IE 9.